Forum

Αναζήτηση στο ms-office.gr

Πάμε!
ms-office.gr > Forum > Microsoft Office > Visual Basic .NET > Αλγοριθμος ΑΦΜ και μετατροπη σε batch script

Visual Basic .NET Ερωτήσεις / Απαντήσεις σε σχέση με τη χρήση της Visual Basic .NET.

Απάντηση στο θέμα

 

Εργαλεία Θεμάτων Τρόποι εμφάνισης
  #1  
Παλιά 18-02-21, 10:22
Όνομα: ΓΙΑΝΝΗΣ
Έκδοση λογισμικού Office: Ms-Office 2016
Γλώσσα λογισμικού Office: Ελληνική, Αγγλική
 
Εγγραφή: 14-02-2021
Μηνύματα: 3
Προεπιλογή Αλγοριθμος ΑΦΜ και μετατροπη σε batch script

Μπορει καποιος να με βοηθήσει ώστε να μετατρέψω τον παρακάτω αλγόριθμο σε batch script ?



Παράθεση:
ΠΡΟΓΡΑΜΜΑ AFM_check
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x, S, ΥΠΟΛΟΙΠΟ, i ,Σ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε 1-1 τα ψηφία του ΑΦΜ'
Σ <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 9
ΔΙΑΒΑΣΕ x
Σ <-- Σ + 2^(9-i)*x
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

S <-- Σ-x

ΥΠΟΛΟΙΠΟ <-- S MOD 11

!ΠΡΟΣΟΧΗ: Επειδή διαιρούμε με το 11 υπάρχει περίπτωση το υπόλοιπο είναι 10.
!Αν είναι 10 το τελευταίο ψηφίο του ΑΦΜ πρέπει να είναι 0 για να είναι έγκυρο.

ΑΝ ΥΠΟΛΟΙΠΟ =10 ΤΟΤΕ
ΥΠΟΛΟΙΠΟ <-- 0
ΤΕΛΟΣ_ΑΝ

ΑΝ ΥΠΟΛΟΙΠΟ = x ΤΟΤΕ
ΓΡΑΨΕ 'ΤΟ ΑΦΜ ΕΙΝΑΙ ΣΩΣΤΟ'
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΤΟ ΑΦΜ ΕΙΝΑΙ ΛΑΝΘΑΣΜΕΝΟ'
ΤΕΛΟΣ_ΑΝ


ΓΡΑΨΕ 'Το άθροισμα των ψηφίων είναι',S
ΓΡΑΨΕ 'Το υπόλοιπο της διαίρεσης ειναι',ΥΠΟΛΟΙΠΟ
ΓΡΑΨΕ 'Το τελευταίο ψηφίο του αριθμού είναι το ' ,x

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ AFM_check
Απάντηση με παράθεση
  #2  
Παλιά 01-04-21, 09:14
Όνομα: ΓΙΑΝΝΗΣ
Έκδοση λογισμικού Office: Ms-Office 2016
Γλώσσα λογισμικού Office: Ελληνική, Αγγλική
 
Εγγραφή: 14-02-2021
Μηνύματα: 3
Προεπιλογή

Το script του Τασου ειναι πολυ δυνατο και τα εχει ολα !!
Απάντηση με παράθεση
Απάντηση στο θέμα

Εργαλεία Θεμάτων
Τρόποι εμφάνισης

Δικαιώματα - Επιλογές
Δε μπορείτε να δημοσιεύσετε νέα μηνύματα
Δε μπορείτε να δημοσιεύσετε απαντήσεις
Δεν μπορείτε να επισυνάψετε αρχεία
Δεν μπορείτε να επεξεργαστείτε τα μηνύματα σας

Ο κώδικας ΒΒ είναι σε λειτουργία
Τα Smilies είναι σε λειτουργία
Ο κώδικας [IMG] είναι σε λειτουργία
Ο κώδικας HTML είναι εκτός λειτουργίας
Trackbacks are εκτός λειτουργίας
Pingbacks are εκτός λειτουργίας
Refbacks are εκτός λειτουργίας


Παρόμοια Θέματα

Θέμα Δημιουργός Forum Απαντήσεις Τελευταίο Μήνυμα
[ Εκθέσεις ] Μετατροπή φόρμας SOELLICHA Access - Ερωτήσεις / Απαντήσεις 0 29-01-18 16:35
Μετατροπή ημερομηνίας. sarrpan Access - Ερωτήσεις / Απαντήσεις 4 29-06-15 13:53
[ Εκθέσεις ] Μετατροπή έκθεσης σε PDF gmax Access - Ερωτήσεις / Απαντήσεις 14 16-08-11 09:34
[Γενικά] Μετατροπή ώρας manolis Excel - Ερωτήσεις / Απαντήσεις 2 25-03-11 08:13
[Γενικά] μετατροπή σε ωρα misirlis Excel - Ερωτήσεις / Απαντήσεις 9 07-09-10 10:15


Η ώρα είναι 14:01.